my invisible text

Corel draw not starting saying fonts not installed


User avatar

3 Star Contributor

Posts: 289

Joined: Fri Jun 28, 2013 2:10 pm

Post Fri Mar 23, 2018 10:23 am

Corel draw not starting saying fonts not installed

Problem started last night with the above error message. I tried a repair but it says all was working. Tried to uninstall but says a setup .mxl file is missing may be corrupt. I am unable to do anything with it. System restore has done nothing either. Any clues or even if there is a UK based tech support as I have raised a ticket but am not holding out much hope. This is the subscription service of Coreldraw Suite 2017. I am not technically minded with these things at all. I have followed The Coreldraw manually uninstall instructions from the web site. (Another edit) I haven’t touched the regedit , whatever that is? Have just tried to reinstall and have got a message saying there is already Coreldraw on this machine and I must uninstall it. I can’t as it is not appearing in the programme lists.


User avatar

4 Star Contributor

Posts: 450

Joined: Tue Nov 24, 2015 2:48 pm

Country: United Kingdom (uk)

Post Sun Mar 25, 2018 11:12 am

Corel draw not starting saying fonts not installed

Try this. Install program called Total Uninstaller. Removes all remaining parts of old programs and then you can install new Corel. Worked for me. Let me know how you get on.

4 Star Contributor

Posts: 424

Joined: Sun Aug 07, 2016 11:54 am

Post Sun Mar 25, 2018 11:26 am

Re: Corel draw not starting saying fonts not installed

Would probably call a computer tech before Corel, if you’re ally stuck. Called them before, were useless, geezer had no clue, and got a bill at end of the month for £70 from EE which I didn’t realise at the time. Prob in to much of a rage at the time as there subscription suddenly required windows 10 and nothing else.

User avatar

L-Gold Member
L-Gold Member

Posts: 2148

Joined: Wed Jan 14, 2004 6:29 pm

Post Wed Mar 28, 2018 8:28 pm

Re: Corel draw not starting saying fonts not installed

Have you tried launching Draw with F8 repeatably pressed, you will be prompted to use factory default workspace, use this workspace, do the same with font manager (try the fontmanager first).
Corrupt workspaces can cause all sorts of problems and resetting it can sort alot of problems. If you have customised your workspace do back it up and then you can load it again after the reset.
Here is a short video I did on how to customise workspaces for anyone not familiar with it - customising can be a huge time saver.

Return to Corel Software

Who is online

Registered users:
John Hughes


Board Rules
Terms & Conditions


Signapp - iPhone & iPad
Signapp - Android
Vehicle Wrap Training
Vinyl Application Training
Vehicle Wrap Accreditation
UK Sign Group
Site Membership
British Signs & Graphics Assoc.




Who is Online

In total there are 60 users online ::
3 registered, 0 hidden and 57 guests
[based on past 5 minutes]

Most users ever online was
370 on Tue Aug 28, 2018 5:02 pm

Registered users:
John Hughes

Copyright © 2000 - 2019 Robert Lambie